古いXcodeをアップデートしようとしても、エラーできない。


UnityHubで、unity2019を扱う際に、iOSビルドサポートが必要だが、 何度やっても、インストール途中で止まる。 このマシンでxcodeを1年近く使っていないのが問題か。
久しくアップデートしていないせいか、xcodeが起動しない。 xcodeのアップデートもうまくいかない。

install logは下記

Xcode[2358]: Package: PKLeopardPackage <id=com.apple.pkg.MobileDeviceDevelopment, version=10.3.9000000000.1.1488876279, url=file:///Applications/Xcode.app/Contents/Resources/Packages/MobileDeviceDevelopment.pkg> Failed to verify with error: Error Domain=PKInstallErrorDomain Code=102 "The package “MobileDeviceDevelopment.pkg” is untrusted." UserInfo={NSLocalizedDescription=The package “MobileDeviceDevelopment.pkg” is untrusted., NSURL=MobileDeviceDevelopment.pkg -- file:///Applications/Xcode.app/Contents/Resources/Packages/, PKInstallPackageIdentifier=com.apple.pkg.MobileDeviceDevelopment, NSUnderlyingError=0x7feaec7f2c00 {Error Domain=NSOSStatusErrorDomain Code=-2147409654 "CSSMERR_TP_CERT_EXPIRED" UserInfo={SecTrustResult=5, PKTrustLevel=PKTrustLevelExpiredCertificate, NSLocalizedFailureReason=CSSMERR_TP_CERT_EXPIRED}}}

上記エラーで ぐぐると色々問題が。 https://stackoverflow.com/questions/58550284/mobiledevice-pkg-untrusted-cannot-open-xcode-after-os-x-update

一番よさそうなのが、xcodeをアンインストールしてから、 入れ直した方が良さそう。


xcodeを関連ファイルをまとめてアンインストール。
↓削除参考

https://qiita.com/UJIPOID/items/015805c89bddca540129

削除する際は、sudo権限でじゃないとアンインストールできないものもある。


ついでに、macのOSアップデートをサボっていたので、 macOSをHigh sierraから catalina へ飛び級アップグレード。

macOSのアップグレードはうまくいったので、次はxcode。

そして、xcodeをappstoreからインストール。
install conponentsが満タンになっても数時間反応がなかったので、
macを再起動して再度xcodeを起動し、install componentを走らせたら直った!


macを再起動して再度xcodeを起動し、install componentを走らせたら直った!

あとは、UnityにモジュールにiOSビルドサポートがインストールできれば…

追記2019-11-17

無事UnityのiOSビルドサポートもインストールできた。!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください