admob androidアプリに導入時のメモ(version4.3.1に妥協

結構はまったので、メモ。
admobは日本語ドキュメントがないので、結構はまりました。
特に、admob SDKバージョン4.3.1ではまってしまったのですが、admobの広告表示領域に、下記のようなエラーが表示されて解決できませんでした。。

"You must have AdActivity declared in AndroidManifest.xml with configChanges." 

下記、googleのドキュメントを何度読んでもエラーの原因がわからず、、
http://code.google.com/intl/ja/mobile/ads/docs/android/fundamentals.html

ネット上でも、同様な記事がたくさんありましたが探したものすべてを試してみましたが、結局解決せず、さすがに妥協してバージョン4.3.1ではなく、4.0.4を入れるとあっさり動きました。。(汗
version4.0.4は上記ドキュメントのサンプルより利用しました。

そもそも、上記ドキュメントのサンプルもSDKのバージョンが4.0.4なので本当に4.3.1が動くのか検証もできませんでした。
せめて最新VerのSDKサンプルがあれば納得がいくのですが。

Android版のSDK4.3.1で、コード(XMLに記述しない方法)で書いてうまくいった方是非ご教授いただけますと幸いです!(汗汗

 

“admob androidアプリに導入時のメモ(version4.3.1に妥協” への2件の返信

  1. ビルドのバージョンを14以上にする必要があります。minversionは変える必要はありません。詳しくはこちらに書いてありました。http://androyer.blogspot.jp/2011/12/admob-version-431.html

    1. ロウキルさん はじめてまして!
      解決策ありがとうございます!まさかapiレベルの設定で解決するんですね、、!
      また、わかりやすい参考サイトまで、大変たすかりました!
      ありがとうございます!m(_ _)m

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください